Thu, 02 Dec 2021 17:16:20 UTC

Information for RPM libffi-3.1-26.eln103.s390x.rpm

ID22611684
Namelibffi
Version3.1
Release26.eln103
Epoch
Archs390x
SummaryA portable foreign function interface library
DescriptionCompilers for high level languages generate code that follow certain conventions. These conventions are necessary, in part, for separate compilation to work. One such convention is the "calling convention". The calling convention is a set of assumptions made by the compiler about where function arguments will be found on entry to a function. A calling convention also specifies where the return value for a function is found. Some programs may not know at the time of compilation what arguments are to be passed to a function. For instance, an interpreter may be told at run-time about the number and types of arguments used to call a given function. `Libffi' can be used in such programs to provide a bridge from the interpreter program to compiled code. The `libffi' library provides a portable, high level programming interface to various calling conventions. This allows a programmer to call any function specified by a call interface description at run time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language. The `libffi' library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. A layer must exist above `libffi' that handles type conversions for values passed between the two languages.
Build Time2020-08-04 01:57:55 GMT
Size32,667
7a6835cf2eb9c3d735be5d4b99a05273
LicenseMIT
Buildrooteln-build-21997264-1831618
Provides
libffi = 3.1-26.eln103
libffi(s390-64) = 3.1-26.eln103
libffi.so.6()(64bit)
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 9 of 9
Name ascending sort Size
/usr/lib/.build-id0
/usr/lib/.build-id/fe0
/usr/lib/.build-id/fe/2f17e1f998a5d4c49b226eca262a96c70afd3d37
/usr/lib64/libffi.so.615
/usr/lib64/libffi.so.6.0.240,048
/usr/share/doc/libffi0
/usr/share/doc/libffi/README15,464
/usr/share/licenses/libffi0
/usr/share/licenses/libffi/LICENSE1,132
Component of
Page:
1 through 50 of 19256 >>>
Buildroot descending sort Created State
eln-build-24313304-2515281 2020-12-02 19:19:18 expired
eln-build-24312629-2515230 2020-12-02 18:57:09 expired
eln-build-24312517-2515230 2020-12-02 18:51:45 expired
eln-build-24312466-2515230 2020-12-02 18:50:06 expired
eln-build-24312453-2515230 2020-12-02 18:49:43 expired
eln-build-24312437-2515230 2020-12-02 18:49:25 expired
eln-build-24311679-2515137 2020-12-02 18:26:26 expired
eln-build-24311122-2515049 2020-12-02 18:08:10 expired
eln-build-24310648-2515049 2020-12-02 18:03:24 expired
eln-build-24309753-2515015 2020-12-02 17:47:25 expired
eln-build-24309752-2515015 2020-12-02 17:47:24 expired
eln-build-24309744-2515015 2020-12-02 17:47:16 expired
eln-build-24309742-2515015 2020-12-02 17:47:15 expired
eln-build-24309728-2515015 2020-12-02 17:46:54 expired
eln-build-24309425-2514859 2020-12-02 17:30:21 expired
eln-build-24309420-2514682 2020-12-02 17:22:26 expired
eln-build-24309404-2514682 2020-12-02 17:18:05 expired
eln-build-24309397-2514682 2020-12-02 17:17:48 expired
eln-build-24309394-2514682 2020-12-02 17:17:40 expired
eln-build-24309391-2514682 2020-12-02 17:17:36 expired
eln-build-24308954-2514544 2020-12-02 16:54:32 expired
eln-build-24308940-2514544 2020-12-02 16:52:42 expired
eln-build-24308938-2514509 2020-12-02 16:52:38 expired
eln-build-24308838-2514448 2020-12-02 16:43:46 expired
eln-build-24308834-2514448 2020-12-02 16:43:43 expired
eln-build-24308817-2514341 2020-12-02 16:35:16 expired
eln-build-24308716-2514172 2020-12-02 16:24:18 expired
eln-build-24308707-2514172 2020-12-02 16:24:10 expired
eln-build-24307140-2513931 2020-12-02 15:31:56 expired
eln-build-24307138-2513931 2020-12-02 15:31:43 expired
eln-build-24306399-2513835 2020-12-02 15:03:32 expired
eln-build-24306302-2513730 2020-12-02 15:00:47 expired
eln-build-24306280-2513730 2020-12-02 15:00:12 expired
eln-build-24306267-2513730 2020-12-02 14:58:52 expired
eln-build-24306095-2513730 2020-12-02 14:53:14 expired
eln-build-24305975-2513730 2020-12-02 14:49:50 expired
eln-build-24305456-2513620 2020-12-02 14:34:55 expired
eln-build-24305440-2513620 2020-12-02 14:33:24 expired
eln-build-24305432-2513620 2020-12-02 14:32:58 expired
eln-build-24305426-2513620 2020-12-02 14:32:47 expired
eln-build-24305423-2513620 2020-12-02 14:32:42 expired
eln-build-24305418-2513620 2020-12-02 14:32:38 expired
eln-build-24305289-2513529 2020-12-02 14:27:30 expired
eln-build-24305280-2513529 2020-12-02 14:27:13 expired
eln-build-24305206-2513529 2020-12-02 14:17:59 expired
eln-build-24305013-2513417 2020-12-02 13:57:28 expired
eln-build-24305010-2513417 2020-12-02 13:57:23 expired
eln-build-24305003-2513417 2020-12-02 13:56:59 expired
eln-build-24305001-2513417 2020-12-02 13:56:59 expired
eln-build-24304997-2513417 2020-12-02 13:56:45 expired